in Blog

WordPress 5.3 でブロックエディタの仕様が変更に。テーマ作者は要確認


日本語チームのタイさんが「WordPress テーマ作者の方は読んでおいたほうがいよい」とのことで、メモです。

WordPressテーマ作者の方は読んどいたほうがいいよー!Preparing Themes For WordPress 5.3 – WordPress Tavern https://wptavern.com/preparing-themes-for-wordpress-5-3#WordPressja

上滝 太祐さんの投稿 2019年10月1日火曜日

投稿内では WP TAVERN の 「Preparing Themes For WordPress 5.3」 という記事と、make.wordpresss.org の「Block Editor Theme-related updates in WordPress 5.3」という記事へのリンクがありました。

11月12日に公開予定の WordPress 5.3 のテーマのための準備と題した記事で、主にブロックエディタ(グーテンベルグ)の仕様変更に対する内容です。

またブロックのCSSをカスタマイズしている方も同様に検証が必要になってくるのでデザインの崩れなどがないか要注意です。

現在カスタムブロックを利用している・作成している方は要チェックですがクラシックエディタを使っている人にはあまり関係はありません。しかし、クラシックエディタを使い続けることは建設的ではないため早めに乗り換えることをおすすめします。

詳しい内容や実際にどのようなクラスに変更されたかなどは後述の記事にまとまっていました。

ということで保守は大変だけど、 WordPress はちゃんと更新しましょうね!

コメントを書く

Comment

CAPTCHA